How to remove the “AMD testing use only” watermark from Debian Wheezy

This script should do the trick:

DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
done

Or you can download it here. And run it as root.

Category(s): Linux, programming, Tech

1,129 Responses to How to remove the “AMD testing use only” watermark from Debian Wheezy

  1. thank you! so much for this great article a day after published :] i accidently downloaded the ati beta graphics driver for ubuntu and found myself with the dreading amd/ati watermark which was a pretty upsetting feeling but this easy script fixed the issue thank you bud oh yeah! dont run in x server run in terminal keep it up ill bookmark this blog and you should take a look at mine also Computer Repair in San Antonio Blog

  2. For 64 bit versions, change the following line for your lib64 (confirmed on Fedora 17 and Ubuntu 12.04):

    DRIVER=/usr/lib64/xorg/modules/drivers/fglrx_drv.so

  3. Titan, you are correct. In fact I first got this script from a Fedora user. So I can confirm for Fedora (idk about ubuntu) that you do have to s/lib/lib64. According to otto (see below) the script works as is for ubuntu 12.04.

    So, please note the original script I posted is for 64-bit Debian Wheezy where the 64bit lib dir is simply lib and not lib64.

  4. Good post, the fix/hack works. I tried in ubuntu 12.04 (64bits) with out changing anything to the script and it works.

    Benedito Carneiro says:

    Your script didn’t work for me (Ubuntu 12.04, AMD64). This one, from http://www.ubunturoot.com/2012/07/remove-amdati-drivers-testing-only.html, worked:

    #!/bin/sh
    DRIVER=/usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
    for x in $(objdump -d $DRIVER|awk ‘/call/&&/EnableLogo/{print “\\x”$2″\\x”$3″\\x”$4″\\x”$5″\\x”$6}’Smilie: ;); do
    sed -i “s/$x/\x90\x90\x90\x90\x90/g” $DRIVER
    done

  5. Thanks, really useful!

    About the lib/lib64 problem, why not changing the script like that so we don’t have to bother :

    instead of : DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
    this : DRIVER=`find /usr -name ‘fglrx_drv.so’ 2> /dev/null`

    like that fglrx_drv.so would be found wherever it is within /usr i think.

  6. I’m getting this error:

    objdump: ‘/usr/lib64/xorg/modules/drivers/fglrx_drv.so’: No such file

    Using ubuntu 12.04 x64, any ideas?

  7. Wow,
    thank you all, it worked like a charm!
    Smilie: :) I have fedora 17 64bit and the file was indeed in lib64, not lib Smilie: :)

  8. Check /usr/lib/ or /lib. Poke around. Each distro is a little different.

  9. Hello guys,

    It works on me. I change the lib to lib64, my OS is Ubuntu 12.10. Maybe the important is the fglrx_drv.so file because when I browse the root folder through /usr the lib64 folder is just a link. I think both ways will work if not thats the time you have to change. Anyway thank you guys for this script, it helps me get rid the AMD watermark.

802 Responses in other blogs/articles

  1. [...] horrible AMD watermark Found a fix for the ugly AMD beta drivers watermark, the script is this link. For Slackware64 just change the line [...]

Leave a Reply

Your email address will not be published. Required fields are marked *


*

 

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>